Lude Generation

The UK Honda Prelude Club

Yet another 4WS thread

Forum Technical Chassis / Brakes / Steering / Wheels

 

Chassis/Brakes/Steering/Wheels discussion
newkid
Supporter 2016
 
Posts: 2368
Joined: Thu Feb 23, 2012
Location: Edinburgh
My Generation: 4G
PSN GamerTag: spaz_ma_taz
Reputation point: 1450
Has liked: 469
Been liked: 468

 Postby newkid »Wed May 23, 2018 7:17 pm

I did reply! Your last two PM's where reminders so no need to reply to them.

I also gave you a fair price which you replied with an offer an then said shipping was outwith UK. I've no problem sending you the part once it's removed along with the fob you asked about as I do still have one spare.

Anzezaf
 
Posts: 62
Joined: Mon Mar 05, 2018
My Generation: 5G
Reputation point: 5
Has liked: 2
Been liked: 3

 Postby Anzezaf »Wed May 23, 2018 8:43 pm

Ah, misunderstanding then. I thought you forgot about me :(

newkid
Supporter 2016
 
Posts: 2368
Joined: Thu Feb 23, 2012
Location: Edinburgh
My Generation: 4G
PSN GamerTag: spaz_ma_taz
Reputation point: 1450
Has liked: 469
Been liked: 468

 Postby newkid »Thu May 24, 2018 10:39 pm

@anzezaf here you go.

Image

Anzezaf
 
Posts: 62
Joined: Mon Mar 05, 2018
My Generation: 5G
Reputation point: 5
Has liked: 2
Been liked: 3

 Postby Anzezaf »Fri May 25, 2018 7:11 pm

After removing my steering wheel to get it wrapped in fresh leather, I decided to see about this sensor, since I had everything open..
I removed it with no problem, it's located behind the stalks as we said multiple times in the thread..
This is how it looks like:
Image
I saw some plastic clips on the outer perimeter and decided to open it..
If someone else sees this post and tries the same procedure I will tell you its easy, but be VERY CAREFUL when undoing these clips as they break super easily, I was gentle and still broke 2 of them..
Anyhoo, the sensor looks like this when its open:
Image
So it is a simple encoder, the metal wheel turns together with the steering wheel, while in the sensor itself there are 2 lights behind a metal slit plate on one side and 2 light-sensing elements on the other side, with the metal disc between them. When the steering wheel turns, the light from the LEDs will pass through the openings on the outside of the disc, or get blocked by the "ribs".
On this basis, the sensor recognizes where and how the steering wheel turns..
So, as you see the sensor was full of gunk and I immediately saw the problem, where one of the lights small opening/slit was totally blocked (red circle on picture) with the gunk , the light sensing elements were partially gunked up (orange circles) and also the disc had some gunk in it.
Image
I cleaned everything up so it was like new (managed to do it with an old toothbrush, vacuum cleaner and air compressor for final pressure-blowing) and put it back together.
Image
After that I reassembled everything in the car and turned it on, and still had the 4ws warning light of course. When I tried resetting with the paperclip procedure, it still wouldn't allow me so my next plan is to visit a Honda mechanic to reset it with a honda program/computer. I am 90% sure it will work afterwards.

no0ne
 
Posts: 44
Joined: Mon Jul 25, 2016
My Generation: 5G
Reputation point: 9
Has liked: 0
Been liked: 6

 Postby no0ne »Fri May 25, 2018 9:56 pm

Get a 4ws ecu without error codes. If sensor is fine, everything should be fine.

Anzezaf
 
Posts: 62
Joined: Mon Mar 05, 2018
My Generation: 5G
Reputation point: 5
Has liked: 2
Been liked: 3

 Postby Anzezaf »Sun May 27, 2018 12:52 pm

GREAT SUCCESS 8-)

Turns out I actually can reset the 4ws code, but I have to turn the steering wheel 90 degrees, instead of the usual 45-60.
This is because my steering isn't aligned yet - the steering wheel is slightly offset from the middle when driving straight.
So today I managed to reset the 4WS and got my first experience driving with it :D :D :D
But it throws an error code very soon after - I can turn around in circles as much as I want and it will work, but as soon as I drive more than 5 meters in a straight line, it throws an error because as I said the steering wheel is not aligned.
I will do the proper 4ws alignment with the locking pin as soon as possible and report back.

Im so happy, finally good progress after 2 months :D

Posts: 286
Joined: Thu Dec 29, 2016
My Generation: 5G
Reputation point: 10
Has liked: 1
Been liked: 18

 Postby Andyjess666 »Sun May 27, 2018 3:06 pm

Well done mate don't we love preludes :lol:


Anzezaf
 
Posts: 62
Joined: Mon Mar 05, 2018
My Generation: 5G
Reputation point: 5
Has liked: 2
Been liked: 3

 Postby Anzezaf »Wed May 30, 2018 4:53 pm

Just wanna say kudos and recommendations for @Scott560 . He sent me the sensor super quick (at that time I didn't fix mine yet) before I even paid him and was really helpful.

10/10 for this guy

Otherwise I'm still waiting for an alignment appointment.. Will report back when I do it.

Anzezaf
 
Posts: 62
Joined: Mon Mar 05, 2018
My Generation: 5G
Reputation point: 5
Has liked: 2
Been liked: 3

 Postby Anzezaf »Mon Jun 11, 2018 3:49 pm

Bad news, did the optical wheel alignment but it still doesn't work. Constantly throwing error 28 - main steering sensor phase Z incorrect. Tried with my sensor, and another one that is supposed to work, so I doubt it's the sensor itself.. Any ideas?

Im also getting concerned about horrible squealing coming out of the 4ws actuator/motor when it does turn.. Anyone tried opening this thing to grease it up?


Forum Technical Chassis / Brakes / Steering / Wheels

Home

The team

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2010 - 2016 - Web by H22 Solutions Limited