Congratulations to Greg for winning February's Lude Of The Month, with his face-lift BA4 >>> Click Here For Profile <<<
Image

ABS pump 4th gen

Chassis/Brakes/Steering/Wheels discussion
Post Reply
Space1999
Posts: 253
Joined: Sat Jan 19, 2013 8:17 pm
My Generation: 3G

ABS pump 4th gen

Post by Space1999 » Tue Jan 08, 2019 10:27 pm

Does anyone know where I can get my ABS pump for my 4th gen VTEC refurbished? It's faulty and throwing a code which means the car can't pass its MOT – so any advice appreciated...

User avatar
wurlycorner
Ye are glad to be dead, RIGHT?
Posts: 20320
Joined: Sat May 19, 2012 3:33 pm
My Generation: 4G
Location: Chelmsford, Essex
Has thanked: 339 times
Been thanked: 50 times

ABS pump 4th gen

Post by wurlycorner » Wed Jan 09, 2019 11:39 am

Don't know anywhere off-hand - there are plenty of places that can deal with more modern units (Can-Bus era with in-built ECU's) but the OBD0/I/II era stuff the aftermarket never geared up for unfortunately.
Now that there is zero oem parts supply and modern classics are very much becoming 'a thing' though, there will be someone out there that can do it I bet.

Best place might be to start looking in some of the classic car magazines?


Do you know what fault code it is giving?

Space1999
Posts: 253
Joined: Sat Jan 19, 2013 8:17 pm
My Generation: 3G

ABS pump 4th gen

Post by Space1999 » Wed Jan 09, 2019 11:53 pm

My garage guy didn't tell me the fault code – but he is sure it is the ABS pump. It needs to be rebuilt or I need to find a working one, because it's lighting up the ABS light so my car can't pass an MOT – despite being lovely in almost every way. Feeling very depressed about it. I've tried breakers, eBay, etc. to no avail.

User avatar
wurlycorner
Ye are glad to be dead, RIGHT?
Posts: 20320
Joined: Sat May 19, 2012 3:33 pm
My Generation: 4G
Location: Chelmsford, Essex
Has thanked: 339 times
Been thanked: 50 times

ABS pump 4th gen

Post by wurlycorner » Thu Jan 10, 2019 12:14 am

You can get the code from the car yourself easy enough and I suggest we do that to confirm the problem, before condemning something that's not the easiest to replace.

EddieMunster
Posts: 110
Joined: Mon Apr 30, 2018 8:31 pm
My Generation: 4G
Has thanked: 8 times
Been thanked: 5 times

ABS pump 4th gen

Post by EddieMunster » Thu Jan 10, 2019 8:31 am

Space1999 wrote:
Wed Jan 09, 2019 11:53 pm
My garage guy didn't tell me the fault code – but he is sure it is the ABS pump. It needs to be rebuilt or I need to find a working one, because it's lighting up the ABS light so my car can't pass an MOT – despite being lovely in almost every way. Feeling very depressed about it. I've tried breakers, eBay, etc. to no avail.
As Wurly says, you only have to bridge 2 pins in a connector under the driver's side dash and the car will tell you what the error is; it's far more likely to be a sensor but follow this link to a visual tutorial of the same.

1. Use this link to locate/setup the jumper: https://92lude.com/diagnose_error_codes.htm
2. If you can't find the jumper, as I did, it may well still be located right behind the stereo which is where it would have been from the factory. If this is the case, move the centre console that has the handbrake/cup holder etc. All you'll need is a cross head, it'll take 2-3 minutes to remove the centre console.
3. Once you've set the jumper, use this link to determine what the error code is:
4. Turn on the ignition, but do not start the engine. The ECU light will remain on, on the dash, and then the corresponding failure section will flash, in your case the ABS light.
5. You'll have 2 sequences of numbers, for the ABS section each sequence will be quick flashes, so count the first sequence and then the second sequence. There'll be a 5 second gap at which point it'll either repeat the first error code if indeed there's only one error, or, it'll move on to the second code. It can store 3 codes at a time, but it's unlikely yours will be more than one.
6. I'll hazard an educated guess that it's a sensor and not a catastrophic failure of the pump, however, the code reading will confirm this.
7. Once you've finished reading the codes, or doing the remedial work, you can remove the pin from the jumper. However, if you're feeling clever, fit a toggle switch, as I have, so that you can turn the code reading on and off at will without having to mess around with a pin etc.

Out of interest, is it just the ABS light that comes on or do you get other warning lights, 4WS for example?
4g 2.2 in Silver, 5g 2.2 Motegi in Blue.

Space1999
Posts: 253
Joined: Sat Jan 19, 2013 8:17 pm
My Generation: 3G

ABS pump 4th gen

Post by Space1999 » Thu Jan 10, 2019 8:58 pm

Thanks for the info, but the garage guy read the fault codes and told me that it indicated a faulty ABS pump. It's just the ABS light that comes on.

So I do need to get my ABS pump rebuilt and/or replaced. It is no longer available new, I can't find a single one in any breakers anywhere in the UK, and no one I know rebuilds them – so that's why I'm here, looking for clues.

So annoying because the car drives gloriously and it's been stuck in the garage's car park for months now as we try to find an answer.

EddieMunster
Posts: 110
Joined: Mon Apr 30, 2018 8:31 pm
My Generation: 4G
Has thanked: 8 times
Been thanked: 5 times

ABS pump 4th gen

Post by EddieMunster » Thu Jan 10, 2019 9:05 pm

Space1999 wrote:
Thu Jan 10, 2019 8:58 pm
So annoying because the car drives gloriously and it's been stuck in the garage's car park for months now as we try to find an answer.
I've just noticed, you have a 3g?
4g 2.2 in Silver, 5g 2.2 Motegi in Blue.

Space1999
Posts: 253
Joined: Sat Jan 19, 2013 8:17 pm
My Generation: 3G

ABS pump 4th gen

Post by Space1999 » Thu Jan 10, 2019 11:24 pm

I have both a 3G and a 4G - the 4G is giving me the trouble...

EddieMunster
Posts: 110
Joined: Mon Apr 30, 2018 8:31 pm
My Generation: 4G
Has thanked: 8 times
Been thanked: 5 times

ABS pump 4th gen

Post by EddieMunster » Fri Jan 11, 2019 6:19 am

Space1999 wrote:
Thu Jan 10, 2019 11:24 pm
I have both a 3G and a 4G - the 4G is giving me the trouble...
If it's for a 4g, they're not at all hard to find; indeed, I know of one that's in great condition, PM me and I'll give you the details.
4g 2.2 in Silver, 5g 2.2 Motegi in Blue.

User avatar
wurlycorner
Ye are glad to be dead, RIGHT?
Posts: 20320
Joined: Sat May 19, 2012 3:33 pm
My Generation: 4G
Location: Chelmsford, Essex
Has thanked: 339 times
Been thanked: 50 times

ABS pump 4th gen

Post by wurlycorner » Sun Jan 13, 2019 3:03 pm

Space1999 wrote:
Thu Jan 10, 2019 8:58 pm
Thanks for the info, but the garage guy read the fault codes and told me that it indicated a faulty ABS pump. It's just the ABS light that comes on.
Obviously it's entirely your choice, but...
Seriously, unless you're absolutely sure that this guy knows 4th gen preludes absolutely inside and out, I really can't suggest strongly enough that we verify that diagnosis before you go changing it.
It's a very simple (and free) task to check it and we can confirm for you, before embarking on what is not an easy job to change that unit (access is a nightmare and it's not easy to do it without distorting the hard brake lines).

Post Reply

Return to “Chassis / Brakes / Steering / Wheels”