Congratulations to Greg for winning February's Lude Of The Month, with his face-lift BA4 >>> Click Here For Profile <<<
Image

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Chassis/Brakes/Steering/Wheels discussion
Post Reply
tontoe
Posts: 16
Joined: Fri Nov 29, 2013 8:49 am
My Generation: 3G
Has thanked: 1 time

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Post by tontoe » Sun Aug 11, 2019 7:37 pm

I'm desperately trying to find a replacement NSF ABS sensor for my 1990 4WS 2.0i 16v Manual Prelude.

It flew through the MOT in July, but now the ABS light has come on and diagnostics say it is the ABS sensor. I've lavished a lot care [and money] in restoring this, but if I can't find a sensor it will fail its MOT next year.

I read somewhere that Rover 600 ABS sensors are the same. Can anybody confirm that?

Or does anyone know of somewhere that could somehow repair the existing one?

Online
Scott560
Posts: 567
Joined: Sat Aug 31, 2013 4:44 pm
My Generation: 5G
Location: Didcot
Been thanked: 22 times

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Post by Scott560 » Sun Aug 11, 2019 10:56 pm

It's your lucky day - I'm off to see my dad tomorrow and he has a ronda 600. I'll get a picture and some measurements if possible. His is the boggo SOHC 2litre non-vtec (no 600 came with vtec, despite being an accord underneath).

I suspect many sensor gubbins from that era are the same, and the difference in part numbers / compatibility is purely down to brackets / cable length / connector which is important, but not drastically so if its keeping a car off the road.
'00 UKDM 2.2VTI H22a8
'97 UKDM 2.2VTi (Gone)

tontoe
Posts: 16
Joined: Fri Nov 29, 2013 8:49 am
My Generation: 3G
Has thanked: 1 time

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Post by tontoe » Mon Aug 12, 2019 9:53 am

Thanks mate, that is really good of you.
Yes - I think lots of the stuff back then was the same - just rebadged etc.
I had a Triumph Acclaim which was basically a British-made shell with Honda engine & components...

Online
Scott560
Posts: 567
Joined: Sat Aug 31, 2013 4:44 pm
My Generation: 5G
Location: Didcot
Been thanked: 22 times

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Post by Scott560 » Mon Aug 12, 2019 8:00 pm

Bad news - didn't have a great day at my dads and ran out of time, so no sensor details I'm afraid. Not likely to see him for a while so I wouldn't wait up on any confirmation details from me. Sorry to be a let down!
'00 UKDM 2.2VTI H22a8
'97 UKDM 2.2VTi (Gone)

tontoe
Posts: 16
Joined: Fri Nov 29, 2013 8:49 am
My Generation: 3G
Has thanked: 1 time

3rd gen 4WS & Rover 600 ABS Sensor - the same unit?

Post by tontoe » Tue Aug 13, 2019 11:40 pm

Never mind - thanks for getting back to me...

Post Reply

Return to “Chassis / Brakes / Steering / Wheels”